intersectsFrustum Method

Determines whether a Frustum intersects with or is fully contained within these frustum planes.

intersectsFrustum(box: Frustum, sphere?: BoundingSphere): boolean

@returns true if box is not entirely outside of the clipping planes.

Parameter Type Description
box Frustum The frustum to test for containment.
sphere BoundingSphere An optional spherical bounding volume fully containing box. If supplied, this can reduce the amount of computation required.

Returns - boolean

true if box is not entirely outside of the clipping planes.

Defined in

Last Updated: 16 April, 2024