QPoint3dBuffer Namespace

Function

Name Description
QPoint3dBuffer.getQPoint Extracts the point at the specified index from a buffer.
QPoint3dBuffer.unquantizePoint Extracts and unquantizes the point at the specified index from a buffer.

Defined in

QPoint3dBuffer Interface

A compact representation of a list of QPoint3ds stored in a Uint16Array. This representation is particularly useful when passing data to WebGL; for example, see RealityMeshParams.positions.

Properties

Name Type Description
params QParams3d The parameters used to quantize the QPoint3dBuffer.points.  
points Uint16Array The QPoint3ds as pairs of unsigned 16-bit integers.  

Defined in

Last Updated: 16 April, 2024