ecefLocation

Accessor

The EcefLocation of the iModel in Earth Centered Earth Fixed coordinates. If the iModel property geographicCoordinateSystem is not defined then the ecefLocation provides a geolocation by defining a 3D coordinate system relative to the Earth model WGS84. Refer to additional documentation for details. If the geographicCoordinateSystem property is defined then the ecefLocation must be used with care. When the geographicCoordinateSystem is defined it indicates the iModel cartesian space is the result of a cartographic projection. This implies a flattening of the Earth surface process that results in scale, angular or area distortion. The ecefLocation is then an approximation calculated at the center of the project extent. If the project is more than 2 kilometer in size, the ecefLocation may represent a poor approximation of the effective cartographic projection used and a linear transformation should then be calculated at the exact origin of the data it must position.

ecefLocation: undefined | EcefLocation

@see GeoLocation of iModels

Returns - undefined | EcefLocation


Setter

The location of the iModel in Earth Centered Earth Fixed coordinates. iModel units are always meters

ecefLocation(ecefLocation: undefined | EcefLocation): void

Parameter Type Description
ecefLocation undefined | EcefLocation  

Returns - void

Defined in

Last Updated: 16 April, 2024