UpgradeOptions Interface

Arguments to validate and update the profile and domain schemas when opening a Db

Properties

Name Type Description
domain Readonly undefined | DomainOptions Option to control the validation and upgrade of domain schemas in the Db  
profile Readonly undefined | ProfileOptions Options that control whether a profile upgrade should be performed when opening a file  
schemaLockHeld Readonly undefined | boolean Options that will allow data transform during Profile/Domain schema upgrade  

Defined in

Last Updated: 16 April, 2024