getLocalizedKeys Method

Replace all instances of %{key} within a string with the translations of those keys. For example:

"MyKeys": { "Key1": "First value", "Key2": "Second value" }
getLocalizedKeys("string with %{MyKeys.Key1} followed by %{MyKeys.Key2}!"") // returns "string with First Value followed by Second Value!"

getLocalizedKeys(inputString: string): string

Parameter Type Description
inputString string  

Returns - string

Defined in

Last Updated: 29 April, 2025