MapSubLayerProps Interface

JSON representation of the settings associated with a map sublayer included within a MapLayerProps. A map sub layer represents a set of objects within the layer that can be controlled separately. These are produced only from map servers that produce images on demand and are not supported by tiled (cached) servers.

@see MapLayerProps

Properties

Name Type Description
children undefined | SubLayerId[]    
id undefined | SubLayerId    
name string    
parent undefined | SubLayerId    
title undefined | string    
visible undefined | boolean    

Defined in

Last Updated: 16 April, 2024