RenderFeatureTable Interface

Representation of a FeatureTable suitable for use with RenderSystem.createBatch. The Features are represented as PackedFeatures. The feature table may contain features from multiple Models.

@see FeatureTable.pack to produce a RenderFeatureTable.

Methods

Name Description
findElementId(featureIndex: number): undefined | string Find the Id of the element associated with the feature at the specified index.  
findFeature(featureIndex: number, result: ModelFeature): undefined | ModelFeature Find the feature at the specified index.  
getElementIdPair(featureIndex: number, out: Uint32Pair): Uint32Pair Get the Id of the element associated with the feature at the specified index as a pair of 32-bit integers.  
getFeature(featureIndex: number, result: ModelFeature): ModelFeature Get the feature at the specified index.  
getModelIdPair(featureIndex: number, out: Uint32Pair): Uint32Pair Get the Id of the model associated with the feature at the specified index.  
getPackedFeature(featureIndex: number, result: PackedFeature): PackedFeature Get the feature at the specified index.  
iterable(output: PackedFeatureWithIndex): Iterable<PackedFeatureWithIndex> Get an object that provides ordered iteration over all features.  

Properties

Name Type Description
batchModelId Readonly string The "model Id" of the tile tree containing the tile from which this feature table originated.  
batchModelIdPair Readonly Uint32Pair A split representation of RenderFeatureTable.batchModelId, to avoid having to constantly having to parse the string.  
byteLength Readonly number The number of bytes consumed by the feature table, strictly for diagnostic purposes.  
numFeatures Readonly number The number of features in the table; equivalently, one more than the largest feature index.  
type Readonly BatchType    

Defined in

Last Updated: 16 April, 2024