RpcActivity Interface

The properties of an RpcActivity.

Extends

Properties

Name Type Description
accessToken Readonly string access token for authorization  
activityId Readonly string Used for logging to correlate an Rpc activity between frontend and backend  
rpcMethod Readonly undefined | string the name of the current rpc method  
user Readonly undefined | string    

Inherited properties

Name Type Inherited from Description
applicationId Readonly string SessionProps Used for logging and usage tracking to identify the application
applicationVersion Readonly string SessionProps Used for logging and usage tracking to identify the application version
sessionId Readonly string SessionProps Used for logging to identify a session

Defined in

Last Updated: 15 March, 2024