RpcInterface Class
An RPC interface is a set of operations exposed by a service that a client can call, using configurable protocols, in a platform-independent way. TheRpcInterface class is the base class for RPC interface definitions and implementations.
Extended by
Methods
Name | Description | |
---|---|---|
constructor(routing: RpcRoutingTokenRpcRoutingToken.default): RpcInterface | ||
forward<T>(parameters: IArguments): Promise<T> | Obtains the implementation result for an RPC operation. | |
isVersionCompatible(backend: string, frontend: string): boolean Static | Determines whether the backend version of an RPC interface is compatible (according to semantic versioning) with the frontend version of the interface. |
Defined in
- core/common/src/RpcInterface.ts Line 46
Last Updated: 13 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.