AreaPattern.HatchDefLineProps Interface

Single hatch line definition

Implemented by

Properties

Name Type Description
angle undefined | AngleProps Angle of hatch line, 0.0 if undefined  
dashes undefined | number[] Array of gap and dash lengths for creating non-solid hatch lines, max of 20.  
offset undefined | XYProps Offset of successive lines.  
through undefined | XYProps Origin point (relative to placement) the hatch passes through, 0.0,0.0 if undefined  

Defined in

Last Updated: 16 April, 2024