Gradient Namespace

Namespace containing types for defining a color gradient, often used for filled planar regions.

Enumeration

Name Description
Gradient.Flags Flags applied to a Gradient.Symb.
Gradient.Mode Enumerates the modes by which a Gradient.Symb's keys are applied to create an image.

Class

Name Description
Gradient.KeyColor Gradient fraction value to ColorDef pair
Gradient.Symb Multi-color area fill defined by a range of colors that vary by position.

Interface

Name Description
Gradient.KeyColorProps Gradient fraction value to ColorDef pair
Gradient.ProduceImageArgs Arguments supplied to Gradient.Symb.produceImage.
Gradient.SymbProps Multi-color area fill defined by a range of colors that vary by position

Function

Name Description
Gradient.keyColorEquals Compare two KeyColor objects for equality.

Defined in

Last Updated: 16 April, 2024