ModelSelectorProps Interface

Properties that define a ModelSelector

Extends

Properties

Name Type Description
models Id64Array    

Inherited properties

Name Type Inherited from Description
classFullName string DefinitionElementProps The full name of the ECClass for this entity, in the form "Schema:ClassName"
code CodeProps DefinitionElementProps The Code for this element
federationGuid undefined | string DefinitionElementProps A FederationGuid assigned to this element.
id undefined | string DefinitionElementProps The Id of the entity.
isInstanceOfEntity Readonly undefined | undefined DefinitionElementProps A non-existent property used to discriminate between EntityProps and Entity.
isPrivate undefined | boolean DefinitionElementProps  
jsonProperties undefined | any DefinitionElementProps Optional json properties of this element.
model string DefinitionElementProps The Id of the Model containing this element
parent undefined | RelatedElementProps DefinitionElementProps The Parent of this element, if defined.
userLabel undefined | string DefinitionElementProps A user-assigned label for this element.

Defined in

Last Updated: 16 April, 2024