constructor Method

Construct an array whose contents are in blocked (row-major) order, possibly with extra capacity.

  • Total capacity is this._data.length
  • Actual in-use count is this._inUse * this._blockSize

GrowableBlockedArray(blockSize: number, initialBlocks: number = 8, growthFactor?: number): GrowableBlockedArray

Parameter Type Description
blockSize number number of entries in each block, i.e., row size
initialBlocks number initial capacity in blocks (default 8)
growthFactor number used by ensureBlockCapacity to expand requested reallocation size (default 1.5)

Returns - GrowableBlockedArray

Defined in

Last Updated: 16 April, 2024