copyData MethodProtected

Copy data from source array. Does not reallocate or change active block count.

copyData(source: Float64Array | number[], sourceCount?: number, destOffset?: number): { count: number, offset: number }

@returns count and offset of blocks copied

Parameter Type Description
source Float64Array | number[] array to copy from
sourceCount number copy the first sourceCount blocks; all blocks if undefined
destOffset number copy to instance array starting at this block index; zero if undefined

Returns - { count: number, offset: number }

count and offset of blocks copied

Defined in

Last Updated: 16 April, 2024