copyData MethodProtected

Copy xyz points from source array. Does not reallocate or change active point count.

copyData(source: Float64Array | number[], sourceCount?: number, destOffset?: number): { count: number, offset: number }

@returns count and offset of points copied

Parameter Type Description
source Float64Array | number[] array to copy from
sourceCount number copy the first sourceCount points; all points if undefined
destOffset number copy to instance array starting at this point index; zero if undefined

Returns - { count: number, offset: number }

count and offset of points copied

Defined in

Last Updated: 16 April, 2024