create MethodStatic

Create an array from various point data formats. Valid inputs are:

  • Point2d
  • Point3d
  • An array of 2 doubles
  • An array of 3 doubles
  • A GrowableXYZArray
  • Any json object satisfying Point3d.isXYAndZ
  • Any json object satisfying Point3d.isXAndY
  • A Float64Array of doubles, interpreted as xyzxyz
  • An array of any of the above

create(data: any, result?: GrowableXYZArray): GrowableXYZArray

Parameter Type Description
data any source points.
result GrowableXYZArray optional pre-allocated GrowableXYZArray to clear and fill.

Returns - GrowableXYZArray

Defined in

Last Updated: 16 April, 2024