setFrom Method

Set this interval from another, with conditional replacements:

  • Always reference the same points as other.
  • use optional begin and end arguments if present; if not take begin and and from other.
  • cap end at points.length.

setFrom(other: IndexedCollectionInterval<T>, base?: number, limit?: number): void

Parameter Type Description
other IndexedCollectionInterval<T>  
base number  
limit number  

Returns - void

Defined in

Last Updated: 16 April, 2024