dotProductIndexIndexXYAndZ Method

Return the dot product of the vectors from the point at origin to the point at indexA and to targetB.

dotProductIndexIndexXYAndZ(origin: number, indexA: number, targetB: Readonly<WritableXYAndZ>): undefined | number

@returns undefined if index is out of bounds

Parameter Type Description
origin number index of point within the array; origin of both vectors
indexA number index of point within the array; target of the first vector
targetB Readonly<WritableXYAndZ> target for second vector

Returns - undefined | number

undefined if index is out of bounds

Defined in

Last Updated: 16 April, 2024