WeightStyle Enumeration

Enumeration of how weights are carried

  • UnWeighted (0) -- there are no weights
  • WeightsAlreadyAppliedToCoordinates (1) -- for real point (x,y,z) the homogeneous point (wx,wy,wx,w) is stored as (wx,wy,wz,w)
  • WeightsSeparateFromCoordinates (2) -- for real point (x,y,z) the homogeneous point (wx,wy,wx,w) is stored as (x,y,z,w)
    • Note that "internal" computations never use WeightsSeparateFromCoordinates.
    • WeightsSeparateFromCoordinates is only useful as input or output state in serializer.

Members

Name Value Description
UnWeighted There are no weights.
WeightsAlreadyAppliedToCoordinates * Data is weighted.
* The point with normalized coordinate [x,y,z] and weight w is stored as [x*w,y*w,z*w,w]
WeightsSeparateFromCoordinates * Data is weighted.
* The point with normalized coordinate [x,y,z] and weight w is stored as [x,y,z,w]

Defined in

Last Updated: 16 April, 2024