createSweptPolyline MethodStatic

  • Create a convex clip set for a polygon swept with possible tilt angle.
  • planes are constructed by ClipPlane.createEdgeAndUpVector, using successive points from the array.
  • If the first and last points match, the polygon area is checked. If the area is negative, points are used in reverse order.
  • If first and last points do not match, points are used in order given

createSweptPolyline(points: Point3d[], upVector: Vector3d, tiltAngle?: Angle): undefined | ConvexClipPlaneSet

Parameter Type Description
points Point3d[] polygon points. (Closure point optional)
upVector Vector3d primary sweep direction, as applied by ClipPlane.createEdgeAndUpVector
tiltAngle Angle angle to tilt sweep planes away from the sweep direction.

Returns - undefined | ConvexClipPlaneSet

Defined in

Last Updated: 16 April, 2024