setPlaneAndXYLoopCCW MethodStatic

Set (or reset) a plane and ConvexClipPlaneSet for a convex array, such as a convex facet used for xy clip.

  • The planeOfPolygon is (re)initialized with the normal from 3 points, but not otherwise referenced.
  • The ConvexClipPlaneSet is filled with outward normals of the facet edges as viewed to xy plane.

setPlaneAndXYLoopCCW(points: GrowableXYZArray, planeOfPolygon: ClipPlane, frustum: ConvexClipPlaneSet): void

Parameter Type Description
points GrowableXYZArray  
planeOfPolygon ClipPlane  
frustum ConvexClipPlaneSet  

Returns - void

Defined in

Last Updated: 16 April, 2024