almostEqualArrays MethodStatic

Test for match of two arrays of type T. Returns true if both arrays have the same length and have the same entries (or both are empty arrays).

almostEqualArrays<T>(a: undefined | T[], b: undefined | T[], testFunction: (p: T, q: T) => boolean): boolean

Parameter Type Description
a undefined | T[]  
b undefined | T[]  
testFunction (p: T, q: T) => boolean  

Returns - boolean

Defined in

Last Updated: 16 April, 2024