areEqualAllowUndefined MethodStatic

Test for match of two values of type T.

areEqualAllowUndefined<T>(a: undefined | T, b: undefined | T, resultIfBothUndefined: boolean = true): boolean

@returns true if both values are defined and equal (with ===) and false if both values are defined but not equal or if one is defined and the other undefined.

Parameter Type Description
a undefined | T first value
b undefined | T second value
resultIfBothUndefined boolean returned value when both are undefined

Returns - boolean

true if both values are defined and equal (with ===) and false if both values are defined but not equal or if one is defined and the other undefined.

Defined in

Last Updated: 16 April, 2024