interpolateColor MethodStatic

Interpolate each byte of color0 and color1 as integers.

interpolateColor(color0: number, fraction: number, color1: number): number

Parameter Type Description
color0 number 32-bit RGBA color0
fraction number fractional position. This is clamped to 0..1 to prevent byte values outside their 0..255 range.
color1 number 32-bit RGBA color1

Returns - number

Defined in

Last Updated: 16 April, 2024