addScaledOuterProductInPlace Method
Add scaled values from an outer product of vectors U and V.
- The scaled outer product is a matrix with
rank 1
(all columns/rows are linearly dependent). - This is useful in constructing mirrors and directional scales.
equation
A += s \columnSubXYZ{U}\rowSubXYZ{V}
\\ \matrixXY{A} += s \begin{bmatrix}
U_x * V_x & U_x * V_y & U_x * V_z \\
U_y * V_x & U_y * V_y & U_y * V_z \\
U_z * V_x & U_z * V_y & U_z * V_z \end{bmatrix}
addScaledOuterProductInPlace(vectorU: Vector3d, vectorV: Vector3d, scale: number): void
Parameter | Type | Description |
---|---|---|
vectorU | Vector3d | first vector in the outer product. |
vectorV | Vector3d | second vector in the outer product. |
scale | number | scale factor to apply to the added values. |
Returns - void
Defined in
- geometry3d/Matrix3d.ts Line 2576
Last Updated: 29 April, 2025
Found something wrong, missing, or unclear on this page? Raise an issue in our repo.