applyGivensColumnOp Method

Replace current columns Ui and Uj with (cUi + sUj) and (cUj - sUi).

  • There is no checking for i,j being 0,1,2.
  • The instance matrix A is multiplied in place on the right by a Givens rotation G, resulting in the matrix A*G.
  • This is used in compute intensive inner loops

applyGivensColumnOp(i: number, j: number, c: number, s: number): void

Parameter Type Description
i number first row index. must be 0,1,2 (unchecked)
j number second row index. must be 0,1,2 (unchecked)
c number fist coefficient
s number second coefficient

Returns - void

Defined in

Last Updated: 13 May, 2024