createColumnsInAxisOrder MethodStatic

Create a matrix by distributing vectors to columns in one of 6 orders.

createColumnsInAxisOrder(axisOrder: AxisOrder, columnA: Vector3d, columnB: Vector3d, columnC: Vector3d, result?: Matrix3d): Matrix3d

Parameter Type Description
axisOrder AxisOrder identifies where the columns are placed.
columnA Vector3d vector to place in the column specified by first letter in the AxisOrder name.
columnB Vector3d vector to place in the column specified by second letter in the AxisOrder name.
columnC Vector3d vector to place in the column specified by third letter in the AxisOrder name.
result Matrix3d optional result matrix3d
* Example: If you pass AxisOrder.YZX, then result will be [columnC, columnA, columnB] because
first letter Y means columnA should go to the second column, second letter Z means columnB should
go to the third column, and third letter X means columnC should go to the first column.

Returns - Matrix3d

Defined in

Last Updated: 13 May, 2024