createColumnsXYW MethodStatic
Create a matrix with each column's x,y parts given XAndY
and separate numeric z values.
equation
\begin{bmatrix}U_x & V_x & W_x \\ U_y & V_y & W_y \\ u & v & w \end{bmatrix}
createColumnsXYW(vectorU: Readonly<WritableXAndY>, u: number, vectorV: Readonly<WritableXAndY>, v: number, vectorW: Readonly<WritableXAndY>, w: number, result?: Matrix3d): Matrix3d
Parameter | Type | Description |
---|---|---|
vectorU | Readonly<WritableXAndY> | |
u | number | |
vectorV | Readonly<WritableXAndY> | |
v | number | |
vectorW | Readonly<WritableXAndY> | |
w | number | |
result | Matrix3d |
Returns - Matrix3d
Defined in
- geometry3d/Matrix3d.ts Line 862
Last Updated: 29 April, 2025
Found something wrong, missing, or unclear on this page? Raise an issue in our repo.