createIdentity MethodStatic
Create an identity matrix.
- All diagonal entries (xx,yy,zz) are one
- All others are zero.
- This (rather than "all zeros") is the useful state for most graphics transformations.
equation
\begin{bmatrix}1 & 0 & 0 \\ 0 & 1 & 0 \\ 0 & 0 & 1\end{bmatrix}
createIdentity(result?: Matrix3d): Matrix3d
Parameter | Type | Description |
---|---|---|
result | Matrix3d |
Returns - Matrix3d
Defined in
- geometry3d/Matrix3d.ts Line 603
Last Updated: 29 April, 2025
Found something wrong, missing, or unclear on this page? Raise an issue in our repo.