createUniformScale MethodStatic
Create a matrix with uniform scale factor "s":
equation
\begin{bmatrix}s & 0 & 0 \\ 0 & s & 0\\ 0 & 0 & s\end{bmatrix}
createUniformScale(scaleFactor: number): Matrix3d
Parameter | Type | Description |
---|---|---|
scaleFactor | number |
Returns - Matrix3d
Defined in
- geometry3d/Matrix3d.ts Line 644
Last Updated: 29 April, 2025
Found something wrong, missing, or unclear on this page? Raise an issue in our repo.