multiplyMatrixTransform Method

Multiply this Matrix3d (considered to be a Transform with 0 origin) times other Transform.

  • Note: If this = [A 0] and other = [B b], then this * other is defined as [A*B Ab] because:
    this matrix A promoted to block Transform[A001]other Transform with ‘matrix‘ part B and origin part b[Bb01]product[A001][Bb01]=[ABAb01]\begin{matrix}
    \text{this matrix }\bold{A}\text{ promoted to block Transform} & \blockTransform{A}{0} \\
    \text{other Transform with `matrix` part }\bold{B}\text{ and origin part }\bold{b} & \blockTransform{B}{b}\\
    \text{product}& \blockTransform{A}{0}\blockTransform{B}{b}=\blockTransform{AB}{Ab}
    \end{matrix}

multiplyMatrixTransform(other: Transform, result?: Transform): Transform

Parameter Type Description
other Transform the other Transform to be multiplied to this matrix.
result Transform optional preallocated result to reuse.

Returns - Transform

Defined in

Last Updated: 13 May, 2024