multiplyTransposeVector Method

Multiply the transpose matrix times a vector.

  • This produces the same x,y,z as treating the vector as a row on the left of the (un-transposed) matrix.
    Treating U as a column to the right of transposed matrixreturn column[VxVyVz]=[Axx Ayx AzxAxy Ayy AzyAxz Ayz Azz][UxUyUz]Treating U as a row to the left of untransposed matrixreturn row[Vx Vy Vz]=[Ux Uy Uz][Axx Axy AxzAyx Ayy AyzAzx Azy Azz]\begin{matrix}
    \text{Treating U as a column to the right of transposed matrix\:  return column}&\columnSubXYZ{V}&=&\matrixTransposeSubXY{A}\columnSubXYZ{U} \\
    \text{Treating U as a row to the left of untransposed matrix\: return row}&\rowSubXYZ{V}&=&\rowSubXYZ{U}\matrixXY{A}
    \end{matrix}

multiplyTransposeVector(vector: Vector3d, result?: Vector3d): Vector3d

Parameter Type Description
vector Vector3d  
result Vector3d the vector result (optional)

Returns - Vector3d

Defined in

Last Updated: 13 May, 2024