multiplyTransposeXYZ Method

Multiply the transpose matrix times column using individual numeric inputs.

  • This produces the same x,y,z as treating the vector as a row on the left of the (un-transposed) matrix.
    treating the input as a column vector [xyz] compute [VxVyVz]=AT[xyz]or as a row vector [xyz] compute [Vx Vy Vz]=[xyz]A8888and return V as a Vector3d\begin{matrix}
    \text{treating the input as a column vector } \columnXYZ{x}{y}{z}\text{ compute  }&\columnSubXYZ{V} &= &A^T \columnXYZ{x}{y}{z} \\
    \text{or as a row vector } \rowXYZ{x}{y}{z} \text{ compute }&\rowSubXYZ{V} &= &\rowXYZ{x}{y}{z} A \\
    \phantom{8888}\text{and return V as a Vector3d} & & &
    \end{matrix}
    @param result the vector result (optional)

multiplyTransposeXYZ(x: number, y: number, z: number, result?: Vector3d): Vector3d

Parameter Type Description
x number  
y number  
z number  
result Vector3d  

Returns - Vector3d

Defined in

Last Updated: 13 May, 2024