symmetricEigenvalues Method

Factor this matrix as a product U * lambda * UT where U is an orthogonal matrix and lambda is a diagonal matrix.

  • Note 1: You must apply this function to a symmetric matrix. Otherwise, the lower triangle is ignored and the upper triangle is mirrored to the lower triangle to enforce symmetry.
  • Note 2: This function is replaced by a faster method called fastSymmetricEigenvalues so consider using the fast version instead.

symmetricEigenvalues(leftEigenvectors: Matrix3d, lambda: Vector3d): boolean

Parameter Type Description
leftEigenvectors Matrix3d a matrix that its columns will be filled by the left eigenvectors of this Matrix3d
(allocated by caller, computed and filled by this function). Note that columns of leftEigenVectors will be
mutually perpendicular because this matrix is symmetric.
lambda Vector3d a vector that its entries will be filled by eigenvalues of this Matrix3d (allocated by
caller, computed and filled by this function).

Returns - boolean

Defined in

Last Updated: 13 May, 2024