xyzPlusMatrixTimesCoordinatesToFloat64Array MethodStatic

Treat the 3x3 matrix and origin as a 3x4 matrix.

  • Multiply the 3x4 matrix by [x,y,z,1]
    [M0M1M2OxM3M4M5OyM6M7M8Oz][xyz1]\begin{bmatrix}M_0 & M_1 & M_2 & Ox \\ M_3 & M_4 & M_5 & Oy \\ M_6 & M_7 & M_8 & Oz\end{bmatrix} * \begin{bmatrix}x \\ y \\ z \\ 1\end{bmatrix}

xyzPlusMatrixTimesCoordinatesToFloat64Array(origin: XYZ, matrix: Matrix3d, x: number, y: number, z: number, result?: Float64Array): Float64Array

Parameter Type Description
origin XYZ translation part (xyz in column 3)
matrix Matrix3d matrix part (leading 3x3)
x number x part of multiplied point
y number y part of multiplied point
z number z part of multiplied point
result Float64Array optional preallocated result. If length < 3, a new array is returned.

Returns - Float64Array

Defined in

Last Updated: 16 April, 2024