xyzPlusMatrixTimesWeightedCoordinates MethodStatic

Treat the 3x3 matrix and origin as upper 3x4 part of a 4x4 matrix, with 0001 as the final row. Multiply the 4x4 matrix by [x,y,z,w]

[M0M1M2OxM3M4M5OyM6M7M8Oz0001][xyzw]\begin{bmatrix}M_0 & M_1 & M_2 & Ox \\ M_3 & M_4 & M_5 & Oy \\ M_6 & M_7 & M_8 & Oz \\ 0 & 0 & 0 & 1\end{bmatrix} * \begin{bmatrix}x \\ y \\ z \\ w\end{bmatrix}

xyzPlusMatrixTimesWeightedCoordinates(origin: XYZ, matrix: Matrix3d, x: number, y: number, z: number, w: number, result?: Point4d): Point4d

Parameter Type Description
origin XYZ translation part (xyz in column 3)
matrix Matrix3d matrix part (leading 3x3)
x number x part of multiplied point
y number y part of multiplied point
z number z part of multiplied point
w number w part of multiplied point
result Point4d optional preallocated result.

Returns - Point4d

Defined in

Last Updated: 13 May, 2024