xyzPlusMatrixTimesWeightedCoordinatesToFloat64Array MethodStatic
Treat the 3x3 matrix and origin as upper 3x4 part of a 4x4 matrix, with 0001 as the final row.
Multiply the 4x4 matrix by [x,y,z,w]
equation
\begin{bmatrix}M_0 & M_1 & M_2 & Ox \\ M_3 & M_4 & M_5 & Oy \\ M_6 & M_7 & M_8 & Oz \\ 0 & 0 & 0 & 1\end{bmatrix} * \begin{bmatrix}x \\ y \\ z \\ w\end{bmatrix}
xyzPlusMatrixTimesWeightedCoordinatesToFloat64Array(origin: XYZ, matrix: Matrix3d, x: number, y: number, z: number, w: number, result?: Float64Array): Float64Array
Parameter | Type | Description |
---|---|---|
origin | XYZ | translation part (xyz in column 3) |
matrix | Matrix3d | matrix part (leading 3x3) |
x | number | x part of multiplied point |
y | number | y part of multiplied point |
z | number | z part of multiplied point |
w | number | w part of multiplied point |
result | Float64Array | optional preallocated result. If length < 4, a new array is returned. |
Returns - Float64Array
Defined in
- geometry3d/Matrix3d.ts Line 1830
Last Updated: 29 April, 2025
Found something wrong, missing, or unclear on this page? Raise an issue in our repo.