rectangleXY Method

Return a rectangle that is the cross section as viewed from above (z direction) and at zFraction

rectangleXY(zFraction: number0.0, upwardNormal: booleantrue, addClosure: booleantrue): undefined | Point3d[]

Parameter Type Description
zFraction number plane altitude within the 0..1 z fraction range
upwardNormal boolean true for CCW as viewed from above
addClosure boolean true to add closure edge back to the start

Returns - undefined | Point3d[]

Defined in

Last Updated: 13 May, 2024