createFixedPointAndMatrix MethodStatic

Create a Transform with the specified matrix. Compute an origin (different from the given fixedPoint) so that the fixedPoint maps back to itself. The returned Transform, transforms a point p to M*p + (f - M*f) where f is the fixedPoint (i.e., Tp = M*(p-f) + f).

createFixedPointAndMatrix(fixedPoint: undefined | Readonly<WritableXYAndZ>, matrix: Matrix3d, result?: Transform): Transform

Parameter Type Description
fixedPoint undefined | Readonly<WritableXYAndZ>  
matrix Matrix3d  
result Transform  

Returns - Transform

Defined in

Last Updated: 16 April, 2024