createFlattenAlongVectorToPlane MethodStatic

Return a transformation which flattens space onto a plane, sweeping along a direction which may be different from the plane normal.

createFlattenAlongVectorToPlane(sweepVector: Vector3d, planePoint: Readonly<WritableXYAndZ>, planeNormal: Vector3d): undefined | Transform

Parameter Type Description
sweepVector Vector3d vector for the sweep direction
planePoint Readonly<WritableXYAndZ> any point on the plane
planeNormal Vector3d vector normal to the plane.

Returns - undefined | Transform

Defined in

Last Updated: 16 April, 2024