createOriginAndMatrix MethodStatic

Create a Transform using the given origin and matrix.

  • This is a the appropriate construction when the columns of the matrix are coordinate axes of a local-to-world mapping.
  • This function is a closely related to createFixedPointAndMatrix whose point input is the fixed point of the world-to-world transformation.
  • If origin is undefined, (0,0,0) is used. If matrix is undefined the identity matrix is used.

createOriginAndMatrix(origin: undefined | XYZ, matrix: undefined | Matrix3d, result?: Transform): Transform

Parameter Type Description
origin undefined | XYZ  
matrix undefined | Matrix3d  
result Transform  

Returns - Transform

Defined in

Last Updated: 16 April, 2024