createScaleAboutPoint MethodStatic

Create a Transform which leaves the fixedPoint unchanged and scales everything else around it by a single scale factor. The returned Transform maps a point p to M*p + (f - M*f) where f is the fixedPoint and M is the scale matrix (i.e., Tp = M*(p-f) + f).

createScaleAboutPoint(fixedPoint: Point3d, scale: number, result?: Transform): Transform

Parameter Type Description
fixedPoint Point3d  
scale number  
result Transform  

Returns - Transform

Defined in

Last Updated: 16 April, 2024