multiplyInversePoint3d Method

Multiply the point by the inverse Transform.

  • If for a point p we have Tp = M*p + o = q, then p = MInverse*(q - o) = TInverse q so TInverse Transform has matrix part MInverse and origin part -MInverse*o.
  • Return as a new point or in the optional result.
  • Returns undefined if the matrix part if this Transform is singular.

multiplyInversePoint3d(point: Readonly<WritableXYAndZ>, result?: Point3d): undefined | Point3d

Parameter Type Description
point Readonly<WritableXYAndZ>  
result Point3d  

Returns - undefined | Point3d

Defined in

Last Updated: 16 April, 2024