multiplyInversePoint3dArray Method

Multiply each point in the array by the inverse of this Transform.

  • For a transform T = [M o] the inverse transform T' = [M' -M'o] exists if and only if M has an inverse M'. Indeed, for any point p, we have T'Tp = T'(Mp + o) = M'(Mp + o) - M'o = M'Mp + M'o - M'o = p.
  • If result is given, resize it to match the input points array and update it with original points p[].
  • If result is not given, return a new array.
  • Returns undefined if the matrix part if this Transform is singular.

multiplyInversePoint3dArray(points: Point3d[], result?: Point3d[]): undefined | Point3d[]

Parameter Type Description
points Point3d[]  
result Point3d[]  

Returns - undefined | Point3d[]

Defined in

Last Updated: 16 April, 2024