multiplyInversePoint4d Method

Multiply the homogenous point by the inverse Transform.

  • If for a point p we have Tp = M*p + o = q, then p = MInverse*(q - o) = TInverse q so TInverse Transform has matrix part MInverse and origin part -MInverse*o.
  • This method computes TInverse p = MInverse*p - w*MInverse*o and returns the Point4d formed by TInverse*p in the first three coordinates, and w in the fourth.
  • Logically, this is multiplication by the inverse of the 4x4 matrix formed from the 3x4 instance augmented with fourth row 0001. This is equivalent to the 4x4 matrix formed in similar fashion from the inverse of this instance.
  • Return as a new point or in the optional result.
  • Returns undefined if the matrix part if this Transform is singular.

multiplyInversePoint4d(weightedPoint: Point4d, result?: Point4d): undefined | Point4d

Parameter Type Description
weightedPoint Point4d  
result Point4d  

Returns - undefined | Point4d

Defined in

Last Updated: 16 April, 2024