multiplyTransformMatrix3d Method

Multiply this Transform times other Matrix3d (considered to be a Transform with 0 origin).

  • Note: If this = [A a] and other = [B 0], then this * other is defined as [A*B a] because:
    this Transform with matrix part A and origin part a[Aa01]other matrix B promoted to block Transform[B001]product[Aa01][B001]=[ABa01]\begin{matrix}
     \text{this Transform with matrix part }\bold{A}\text{ and origin part }\bold{a} & \blockTransform{A}{a}\\
     \text{other matrix }\bold{B}\text{ promoted to block Transform} & \blockTransform{B}{0} \\
    \text{product}& \blockTransform{A}{a}\blockTransform{B}{0}=\blockTransform{AB}{a}
    \end{matrix}

multiplyTransformMatrix3d(other: Matrix3d, result?: Transform): Transform

Parameter Type Description
other Matrix3d the other Matrix3d to be multiplied to this Transform.
result Transform optional preallocated result to reuse.

Returns - Transform

Defined in

Last Updated: 16 April, 2024