multiplyTransformTransform Method

Multiply this Transform times other Transform.

  • Note: If this = [A a] and other = [B b] then this * other is defined as [A*B Ab+a] because:
    this Transform with matrix part A and origin part a[Aa01]other Transform with matrix part B and origin part b[Bb01]product[Aa01][Bb01]=[ABAb+a01]\begin{matrix}
     \text{this Transform with matrix part }\bold{A}\text{ and origin part }\bold{a} & \blockTransform{A}{a}\\
     \text{other Transform with matrix part }\bold{B}\text{ and origin part }\bold{b} & \blockTransform{B}{b} \\
    \text{product}& \blockTransform{A}{a}\blockTransform{B}{b}=\blockTransform{AB}{Ab + a}
    \end{matrix}

multiplyTransformTransform(other: Transform, result?: Transform): Transform

Parameter Type Description
other Transform the other Transform to be multiplied to this Transform.
result Transform optional preallocated result to reuse.

Returns - Transform

Defined in

Last Updated: 16 April, 2024