multiplyTransposeXYZW Method

Multiply the homogeneous point by the transpose of this Transform. Return as a new Point4d or in the pre-allocated result (if result is given).

  • If p = (x,y,z) then this method computes M^t*p and returns it in the first three coordinates of the Point4d, and o*p + w in the fourth.
  • Logically, this is multiplication by the transpose of the 4x4 matrix formed from the 3x4 instance augmented with fourth row 0001.

multiplyTransposeXYZW(x: number, y: number, z: number, w: number, result?: Point4d): Point4d

Parameter Type Description
x number  
y number  
z number  
w number  
result Point4d  

Returns - Point4d

Defined in

Last Updated: 16 April, 2024