multiplyVectorXYZ Method

Multiply the vector (x,y,z) by the matrix part of the Transform.

  • The origin part of Transform is not used.
  • If result is given, update it with the multiplication. Otherwise, create a new Vector3d.

multiplyVectorXYZ(x: number, y: number, z: number, result?: Vector3d): Vector3d

Parameter Type Description
x number  
y number  
z number  
result Vector3d  

Returns - Vector3d

Defined in

Last Updated: 16 April, 2024