multiplyXYZW Method

Transform the homogeneous point. Return as a new Point4d, or in the pre-allocated result (if result is given).

  • If p = (x,y,z) then this method computes Tp = M*p + o*w and returns the Point4d formed by Tp in the first three coordinates, and w in the fourth.
  • Logically, this is multiplication by the 4x4 matrix formed from the 3x4 instance augmented with fourth row 0001.

multiplyXYZW(x: number, y: number, z: number, w: number, result?: Point4d): Point4d

Parameter Type Description
x number  
y number  
z number  
w number  
result Point4d  

Returns - Point4d

Defined in

Last Updated: 16 April, 2024